• 已解决 33305 个问题
  • 已帮助 5749 位优秀工程师

STM32F103C8T6最小系统开发板问题?

代人凌峰 2018-11-05 浏览量:368
使用TIM3和TIM4的PWM功能输出8路PWM。软件没问题,刚开始8路都是好的,但是工作的一段时间后PB1、PB9就没有输出了,换了一片单片机又有输出了。可见是单片机IO口烧了。后续又有相同的问题发生,而且就算换了外部接线也是这两个口烧坏。都是第四路输出,不知道有没有遇见相同问题的
单片机 STM32
0 0 收起

我来回答

上传资料:
选择文件 文件大小不超过15M(格式支持:doc、ppt、xls、pdf、zip、rar、txt)
最佳答案
  • 如果确定不是软件的问题的话,建议你在输出引脚上串联一个1K-4.7K的电阻,限流试试
    • 发布于 2018-11-05
    • 举报
    • 评论 0
    • 0
    • 0

其他答案 数量:12
  • 那就是硬件设计问题,可以再中间再加一级驱动
    • 发布于2018-11-05
    • 举报
    • 评论 0
    • 0
    • 0

  • 如果是第四个引脚没有输出后,其他引脚正常输出的话,说明程序问题不大,估计是硬件设计的缺陷,建议加隔离试试,注意隔离电路的开关频率与pwm频率适配
    • 发布于2018-11-06
    • 举报
    • 评论 0
    • 0
    • 0

  • 这两个脚是用来控制什么的?外围电路最好也检查一下。

    • 发布于2018-11-06
    • 举报
    • 评论 0
    • 0
    • 0

  • 这个可能是外部硬件隔离不够造成的,你仔细检查相应电路部分,最好添加合适的隔离措施。
    • 发布于2018-11-06
    • 举报
    • 评论 0
    • 0
    • 0

  • 加隔离和限流电路 主要是跟后面的电路有关
    • 发布于2018-11-06
    • 举报
    • 评论 0
    • 0
    • 0

  • 老烧io肯定是外部电路的原因了,加保护电阻
    • 发布于2018-11-06
    • 举报
    • 评论 0
    • 0
    • 0

  • 你的IO口上接上哪些的设备啊,有没有高电压的。

    单片机设置了低功耗 了没有呢

    • 发布于2018-11-06
    • 举报
    • 评论 0
    • 0
    • 0

  • 这要看你的外接了,如果你外接电机驱动啥的,没做隔离可能会烧掉
    • 发布于2018-11-09
    • 举报
    • 评论 0
    • 0
    • 0

  • 看一下单片机上电的时候,这两个引脚处的电压是多少
    • 发布于2018-11-23
    • 举报
    • 评论 0
    • 0
    • 0

  • 软件问题关系不大,应该是电路的接线导致的,检测一下工作电压是不是3.3V以上?
    • 发布于2018-11-28
    • 举报
    • 评论 0
    • 0
    • 0

  • 这个跟你的硬件有关系,如果噪声干扰比较大的话最好是隔离一下
    • 发布于2018-11-29
    • 举报
    • 评论 0
    • 0
    • 0

  • 这个跟你的硬件有关系,如果噪声干扰比较大的话最好是隔离一下
    • 发布于2018-11-29
    • 举报
    • 评论 0
    • 0
    • 0

STM32F103C8T6最小系统开发板问题?